Smart Phone Compatibility with Echo Series

Currently the Echo Series is compatible with the following Apple products running iOS7 or higher:
- iPhone 4S
- iPhone 5
- iPhone 5C
- iPhone 5S
- iPhone 6
- iPhone 6+
- iPod 5th Gen
- iPad Mini
- iPad 3rd & 4th Gen

Currently the Echo is compatible with the following Android products -
Depending on your network carrier, an upgrade to Andriod kitkat 4.4 may be available. Please contact your carrier if kitkat 4.4 is not yet available for your device.
Echo will work with the below phones running kitkat 4.4:
- Samsung Galaxy S4
- Samsung Galaxy S5
- Motorola Moto E
- Motorola Moto G
- Motorola Moto X
- HTC One (2013)
- HTC One (M8)
- LG G2

Echo will also work with any android phone running lollipop 5.0.

However all android phones must meet the minimum requirement to be compatible:
- Android Kitkat 4.4 or later operating system
- Bluetooth 4.0 or later

Need further Information ?

If the above answer did not give you the answer you were looking for, or you need further information please complete the box below and we will answer your question personally.

Copyright © 2016 MiTAC Intl.